Invalid Exchange Server version using Veeam Backup for Microsoft Office 365 #updated #withSolution


Update: After contacting Veeam support they attended me that there is a private fix voor version 912.

  • stop all jobs
  • stop “Veeam Backup for Microsoft Office 365 Service”
  • replace Veeam.Ews with the DLL from the archive https://storage.veeam.com/Fix_113114_fbcf2c440c.zip in C:\Program Files\Veeam\Backup365 (don’t forget to back up the original DLL)
  • Start “Veeam Backup for Microsoft office 365 Service”
  • retry the job

veeam_o365_error_working

As you can see the problem is solved and I’m able to backup Office 365 again!


People (including me :-))  are reporting problems using Veeam Backup for Microsoft Office 365. It seems that Microsoft made some kind of change on their back-end. At this time Veeam reports that they are looking into the problem..

I’m running Version 1.0.0.912…. a newer version isn’t available on the general download site. So upgrading the Veeam software isn’t the solution for now.

veeam_o365_error_version

Don’t seem to be (Windows) update related. Before and after updating my test server I receive the same error. 🙁

veeam_o365_error

When there is a solution I shall mention this in this blogpost.

Leave a comment

Your email address will not be published. Required fields are marked *