Unable to update to ESXi 4.1 using VC Client Update Manager – “Failed to read the upgrade package metadata.xml”


I ran into some problems usingthe VC Client Update Manager. After checking the .ZIP update file it came with an error.

The solution, download the .ZIP upgrade file, extract it and copy it to your ESXi server using winscp or VC storage browse

Go to the directory where you placed the files and do the manual upgrade to ESXi 4.1 as follows :

Place your ESXi server into maintenance mode;

esxupdate update -m metadata.zip (after that restart your server and check the build level)

You’re al done!

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.